The Levelpath team has fully resolved this incident. Thank you for your patience as we worked to address the issue. If you are still experiencing any issues with Levelpath, please reach out to support@levelpath.com for further assistance.
Posted Oct 15, 2025 - 03:15 PDT
Monitoring
The Levelpath team has deployed a fix and is currently monitoring the status of the platform.
Posted Oct 15, 2025 - 03:07 PDT
Identified
The Levelpath team has identified the root cause of SSO authentication issue and is currently in the process of mitigating the issue.
Posted Oct 15, 2025 - 02:17 PDT
Investigating
Levelpath is currently experiencing SSO authentication issues. You may experience issues accessing Levelpath at this time. The team is currently investigating the root cause.
Posted Oct 15, 2025 - 02:10 PDT
This incident affected: Levelpath Web App, Projects & Hub, Sourcing, Contracts, Risk, Invoice, and Assistant.