Cloud provider services have recovered, and all impacted Levelpath components are now fully operational. Thank you for your patience as we monitored this incident. If you continue to experience any issues, please reach out to support@levelpath.com.
Posted Oct 20, 2025 - 02:43 PDT
Update
Cloud provider services are gradually recovering, and impacted Levelpath features are beginning to return to normal operation. We continue to monitor system performance to ensure stability.
Posted Oct 20, 2025 - 02:32 PDT
Monitoring
Cloud provider services are gradually recovering, and impacted Levelpath features are beginning to return to normal operation. We continue to monitor system performance to ensure stability.
Posted Oct 20, 2025 - 02:30 PDT
Identified
The Levelpath team has identified that the issue is related to an ongoing cloud provider outage. We are monitoring the situation and will share updates as more information becomes available.
Posted Oct 20, 2025 - 01:16 PDT
Investigating
Levelpath is currently experiencing partial disruptions affecting certain features, including contract uploads, OCR processing, and notifications. Our team is investigating and closely monitoring the situation.
Posted Oct 20, 2025 - 01:11 PDT
This incident affected: Levelpath Web App, Projects & Hub, Contracts, and Supplier Hub.